Issues accessing or using Microsoft 365 services in the North America region

Incident Report for Technology Solutions

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 16:25 EDT

Investigating

Users may be experiencing issues accessing or using Microsoft 365 services in the North America region.
Posted Jul 23, 2026 - 12:15 EDT
This incident affected: Collaboration & Communications (Microsoft Office 365).