Microsoft Teams Outage

Incident Report for Technology Solutions

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 14:11 EST

Identified

Technology Solutions is currently investigating an issue affecting Microsoft Teams. Microsoft Teams may show errors or fail to connect because of recent changes in our Microsoft 365 setup. If you're experiencing this issue, please take the steps below:

Restart your computer. If that fails then see below:

Follow the steps below on how to sign out of Teams:

1. Desktop - Click the circle with your profile image or initials in the top right hand corner and click "Sign out." Mobile - Tap your profile image or initials in the top left hand corner, choose "Settings" and "Sign out" at the bottom.

2. Close Teams completely, then reopen and sign in with your current company email address.

If the above did not work, please follow this guide for additional steps:

https://bbins365.sharepoint.com/:b:/r/sites/thespot-dpt-it/Shared%20Documents/Additional%20Teams%20Sign%20In%20Steps.pdf?csf=1&web=1&e=hrqCcc

If you still have trouble after signing out, please reach out to the Technology Solutions Service Desk for further assistance:
• Submit a ticket via the Technology Solutions Service Desk
• Call us at (844) 854-6330
Posted Nov 24, 2025 - 08:16 EST

Investigating

Technology Solutions is currently investigating an issue affecting Microsoft Teams. Microsoft Teams may show errors or fail to connect because of recent changes in our Microsoft 365 setup. If you're experiencing this issue, please take the steps below:

Follow the steps below on how to sign out of Teams:
1. Desktop - Click the circle with your profile image or initials in the top right hand corner and click "Sign out." Mobile - Tap your profile image or initials in the top left hand corner, choose "Settings" and "Sign out" at the bottom.
2. Close Teams completely, then reopen and sign in with your current company email address.
If the above did not work, please follow this guide for additional steps:

https://bbins365.sharepoint.com/:b:/r/sites/thespot-dpt-it/Shared%20Documents/Additional%20Teams%20Sign%20In%20Steps.pdf?csf=1&web=1&e=hrqCcc

If you still have trouble after signing out, please reach out to the Technology Solutions Service Desk for further assistance:
• Submit a ticket via the Technology Solutions Service Desk
• Call us at (844) 854-6330
Posted Nov 21, 2025 - 14:48 EST
This incident affected: Collaboration & Communications (Microsoft Office 365).